Menu

OpenWRT bridged Repeater mit relayd

OpenWRT ist eine auf Linux basierende offene Firmware für Router und AccessPoints. OpenWRT wird permanent weiterentwickelt und steht aktuell in der Version Chaos Calmer (15.05) für eine Vielzahl an Geräten unterschiedlicher Hersteller zur Verfügung. Möchte man in einer Mietwohnung nicht meterweise LAN-Kable an der Sockelleiste entlang verlegen, gibt es die Möglichkeit mit zwei AccessPoints einen WLAN-Blücke aufzubauen.

OpenWRT bietet zwei Möglichkeiten um eine Bridge einzurichte. WDS (Wireless Distribution System) oder relayd. Grundsätzlich ist WDS zwar einfacher zu konfigurieren, hat aber auch Nachteile. Das Protokoll ist nicht standardisiert was bedeutet, dass es zwischen den Herstellern Unterschiede bei der Implementierung gibt. Dadruch kann es passieren, dass Geräte mit unterschiedlichen WLAN-Chipsätzen (atheros/broadcom) garnicht kompatibel sind oder es zu einer instabilen Verbindung kommt. Da ich aber selbst bei gleichem Chipsatz immer wieder Probleme mit WDS hatte, empfehle ich persönlich den Weg über relayd.

Ich benutze für die Bridge zwei TP-Link WDR4300. Die Bridge-Verbindung wird über das 5 GHz Band aufgebaut, alle weiteren Clients nutzen ausschließlich 2,4 GHz. Grundsätzlich sollte relayd auf allen Geräten mit OpenWRT funktionieren, weiter Informationen findet man im Wiki. Alle Geräte die mit der Bridge verbunden sind (LAN und WLAN) befinden sich anschließend im selben IP-Adressbereich. Für das Tutorial gehe ich davon aus, dass ihr bereits OpenWRT auf euren Geräten installiert habt.

Vorbereitung AP1

Die Einstellungen des ersten AccessPoints müssen nicht weiter angepasst werden. Die einzige Voraussetzung ist, dass sich das WLAN Interface, welches ihr für die Bridge benutzen wollt, im Modus Access Point befindet und aktiviert ist. Alle weiteren Schritte werden auf dem zweiten Gerät vorgenommen!

Aktualisierung und Installation benötigter Pakete

Das Paket luci-proto-relay ist optional und wird nur benötigt wenn ihr später das Bridge-Interface über die Weboberfläche (luci) administrieren wollt.

  1. opkg update
  2. opkg list-upgradable
  3. opkg upgrade <package>
  4. opkg install relayd luci-proto-relay
  5. /etc/init.d/relayd enable

WLAN Interface konfigurieren

Anzupassen ist die Datei /etc/config/wireless. Möchtet ihr wie ich den Editor nano benutzen, müsst ihr den erst nachinstallieren der vorinstallierte vi tut es aber auch.

  1. nano /etc/config/wireless
  2. config wifi-device 'radio1'
  3.         option type 'mac80211'
  4.         option hwmode '11a'
  5.         option path 'pci0000:00/0000:00:00.0'
  6.         option channel '36'    # selbe Einstellung wie bei AP1 (Channel kann bei 2,4 GHz abweichen)
  7.         option htmode 'HT40'
  8.         option txpower '15'
  9.         option country 'DE'
  10.  
  11. config wifi-iface
  12.         option device 'radio1'
  13.         option network 'wwan'    # das Interface wwan wird später erstellt
  14.         option ssid 'device-relay'    # selbe Einstellung wie bei AP1
  15.         option mode 'sta'    # bringt das Gerät in den Client-Modus
  16.         option encryption 'psk2+ccmp'    # selbe Einstellung wie bei AP1
  17.         option key 'password'    # selbe Einstellung wie bei AP1

Netzwerkinterface Konfigurieren

  1. nano /etc/config/network
  2. config interface 'lan'
  3.         option ifname 'eth0.1'
  4.         option force_link '1'
  5.         option type 'bridge'
  6.         option proto 'static'
  7.         option ip6assign '60'
  8.         option ipaddr '192.168.10.1'    # muss eine IP außerhalbe eures Adressbereichs sein!
  9.         option netmask '255.255.255.0'
  10.         option gateway '192.168.1.1'   # IP von AP1 (oder separate Firewall/Router)
  11.         option dns '192.168.1.1'    # IP von AP1 (oder separater DNS)
  12.         option stp '1'    # Spanning Tree Protokoll aktivieren
  13.  
  14. # wwan und stabridge anlegen
  15. config interface 'wwan'
  16.         option proto 'static'
  17.         option ipaddr '192.168.1.2'    # über diese IP hat man Zugriff auf das Webinterface
  18.         option netmask '255.255.255.0'
  19.         option gateway '192.168.1.1'
  20.  
  21. config interface 'stabridge'
  22.         option proto 'relay'    
  23.         option ipaddr '192.168.1.2'    # muss die selbe IP wie bei wwan sein
  24.         list network 'lan'
  25.         list network 'wwan'

Optional: DHCP konfigurieren

Wenn ihr bereits einen DHCP Server in eurem Netzwerk eingerichtet habt könnt ihr diesen Schritt überspringen. Achtet darauf, dass ihr diese Einstellungen wieder auf dem ersten AccessPoint vornehmt!

  1. config dhcp 'lan'
  2.     option interface 'lan'
  3.     option start '100'    # Startadresse des DHCP-Adressbereiches hier also 192.168.1.100
  4.     option limit '150'
  5.     option leasetime '12h'
  6.     option ignore '1'
  7.  
  8. config dhcp 'wan'
  9.     option interface 'wan'
  10.     option ignore '1'

Nicht benötigte Dienste abschalten

Da firewall, dhcp und dnsmasq vom AP1 übernommen wird, sollten diese Dienste auf AP2 abgeschaltet werden um Konflikte zu vermeiden. Benutzt ihr beide Geräte als reine AccessPoints, könnt ihr die Dienste auch auf beiden Geräten deaktivieren.

  1. /etc/init.d/firewall stop
  2. /etc/init.d/firewall disable
  3. /etc/init.d/odhcpd stop
  4. /etc/init.d/odhcpd disable
  5. /etc/init.d/dnsmasq stop
  6. /etc/init.d/dnsmasq disable


Abschließend werden beide AccessPoints nochmal neu gestartet - fertig.

Wer möchte kann auf dem zweiten AP noch das 2,4 GHz WLAN aktivieren und einrichten. Alle Geräte die sich mit diesem WLAN verbinden erhalten ebenfalls eine IP aus dem Adressbereich des ersten AP's. Wenn euer Gerät nur ein WLAN Interface hat, lässt sich für die Clients auch ein virtueller Zugangspunkt einrichten.

Euch hat der Beitrag gefallen, ihr habt Fragen oder Anregungen? Hinterlasst mir einen Kommentar oder diskutiert im OSBN-Chat.

Kommentare

Linear Verschachtelt
Any

Any

Hi,
danke für den Artikel, da ich bisher keine Erfahrungen mit OpenWRT habe hier mal eine dumme Frage: Kann man das nicht auch über das Webinterface machen?

Robert Kaussow

Hi Any,
klar prinzipiell sind alle Schritte auch über die GUI möglich. Wichtig ist dass du dann aber unbedingt wie beschrieben das Paket luci-proto-relay mit installierst sonst kannst du das relay-Interface nicht anlegen. Wenn du Hilfe brauchst sag bescheid :-)

Benjamin

Benjamin

Hi Robert,

danke für die tolle Anleitung ;-)
Hab das mal so probiert und es läuft mitlerweile auch halbwegs gut auf einem Widemac sl7205 den ich nun als Repeater nutze. Hauptrouter ist eine Fritzbox.
Unter OpwnWRT musste ich jedoch noch in dem WWAN Iface DHCP aktivieren da die Clients hinter dem Repaeater sonst keine IP bekommen haben. Mit festen IP`s war es kein Problem.
Was hier in der Anleitung nicht steht ist, das ich noch ein 2. Wlan (Radio 0.1) anlegen musste, welches ich als AP konfiguriert habe. SSID und KEY identisch mit den Einstellungen im Hauptrouter. Trotzdem hängt die Verbindung manchmal. nach ein paar sekunden gehts dann wieder. Naja, vielleicht bekomm ich auch das noch in den Griff oder hast Du einen Tipp für mich ? VG, Benjamin

Robert Kaussow

Hi Benjamin,
freut mich, dass es dir geholfen hat. Wenn die Fritzbox bereits als DHCP Server eingerichtet ist, wundert es mich ehrlich gesagt, dass du auf dem zweiten AP noch DHCP aktivieren musstest... Da sich alle Geräte im selben Adressbereich befinden sollte es dort auch nr einen DHCP Server geben.

Wenn man den zweiten AP als Repeater nutzen möchte, muss man einen zweiten WLAN Zugangspunkt einrichten, das ist richtig. Entweder man trennt hier wie beschrieben zwischen 5 und 2,4 GHz Band, hat der AP nur eins von beiden muss Bridge und Repeater über das selbe WLAN laufen, man benötigt dann allerdings einen virtuellen Zugangspunkt. Steht aber auch im letzten Absatz ;-) oder habe ich dich falsch verstanden?

Zu der "hängenden" Verbindung. Ich habe auch festgestellt, dass der Seitenaufbau manchmal ein paar Sekunden dauert. Ich habe allerdings auch noch nicht herausfinden können warum das so ist. Falls du was herausfindest wäre ich sehr Dankbar wenn du mir das mitteilst :-)

Viele Grüße

Max

Max

Wie richte ich das ganze so ein das meine Fritzbox 7490 die IPs 192.168.178.1 bis 192.168.178.99 und mein TP-Link WR841 v8 mit OpenWrt die IPs 192.168.178.100 bis 192.168.178.199?

Robert Kaussow

Hallo Max,

reden wir hier von unterschiedlichen Subnetzen (mit Verwendung einer unterschiedlichen Subnetzmaske) oder vom selben Netz? Prinzipiell sollte in einem IP-Netz immer nur ein DHCP Server betrieben werden. Was willst du denn erreichen? Vielleicht gibt es dafür ja einen besseren Weg.

Niklas

Niklas

Hi Robert,

ich habe bei meinem neuen Anbieter ne Fritzbox 7412 mitbekommen. Muss ich OpenWRT auf dieser auch installieren, um eine zweiten Router (TP-Link wr841nd) als Repeater zu nutzen?

Robert Kaussow

Hi Niklas,

praktisch habe ich das noch nicht probiert, in der Theorie sollte das aber funktionieren :-) Die Fritzbox ist in deinem Fall dann der AP1 dieser sollte sich im Modus AccessPoint befinden. Den zweiten Router von dir konfigurierst du so, wie im Abschnitt AP2 beschrieben. Du solltest dann aber auf dem AP2 unbedingt den DHCP Dienst deaktivieren, das übernimmt weiterhin die Fritzbox.

Sag bitte bescheid ob es funktioniert hat, würde mich auch interessieren ;-)

Dieter

Dieter

Geänderte MAC Adresse

Hi Robert,
vielen Dank für Deine Anleitung. Ich habe das seit einiger Zeit in Betrieb und es läuft soweit ganz gut.
Was mir bisher aber nicht aufgefallen war ist das die Clients hinter der Bridge nicht mit ihrer echten MAC Adresse am primären DHCP Server auftauchen. Stattdessen wird die der Bridge (WWAN) oder bei mehreren dynamische neue MAC Adressen generiert und verwendet.
Soweit ist das erstmal nicht tragisch, weil alles funktioniert.
Möchte man aber die Clients (auch hinter der Bridge) zwingen bestimmte IP Adressen zu verwenden geht das nicht.
Warum möchte man (ich) das? Ganz einfach ich habe 3 Jungendliche im Haus deren Internetnutzung ich in gewissen Bahnen lenken möchte (muss?).
Alle Reglen zur zeitlichen Nutzung oder sperren von bestimmten Inhalten funktionieren aber auf IP Adressen.
Es hat nicht lange gedauert bis die Kids raus gefunden hatten das sie hinter der Bridge eine andere IP manuell einstellen können und so der Zwangszuweisung der Router entgehen.
Im WIKI habe ich gesehen das es einen optionalen Parameter "macaddr" (Override MAC address of this interface) gibt.
So richtig weiss ich nicht ob der richtig ist und wo ich den wie einbauen muss.
Wenn Du eine Idee dazu hast würde ich mich über ein Antwort freuen.
Vielen Dank und Viele Grüße
Dieter

Robert Kaussow

Hallo Dieter,

gut zu wissen, ist mir bisher auch nicht aufgefallen :-) Das Problem, bleibt doch aber weiterhin auch wenn die MAC Adressen nicht überschrieben werden. So lange deine Kinder manuell die IP am PC ändern, laufen alle Regeln die du definierst ins leere. Oder habe ich dich falsch verstanden? Auch MAC-Adressen lassen sich lokal am PC überschreiben, damit sind Regeln auf dieser Grundlage ebenfalls unwirksam.

Folgende Idee (selbst noch nicht getestet):
Richte einen weiteren WLAN Zugangspunkt ein. Für diesen Zugangspunkt kannst du eine eigene Netzwerkzone sowie Firewall-Regeln anlegen. Innerhalb dieser Zone (z. B. "kids") kannst du dann nach belieben Regeln definieren, da diese für die komplette Zone gelten können deine Kinder IP's oder MAC's ändern wie sie wollen :-) Du solltest dann natürlich das Passwort für dein WLAN-Netz ändern und vor deinen Kindern geheim halten. Sollten die PC's deiner Kinder per LAN angeschlossen sein, wird es etwas komplizierter. Hier wäre aber VLAN ein guter Ansatz. Hier mal ein Beitrag aus dem Openwrt-Wiki. Hier geht es zwar um ein Gast-WLAN, mit etwas Anpassung lässt sich aber genau das umsetzten was du möchtest.

Wenn ich etwas Zeit finde, teste ich das mal, das Thema interessiert mich selbst. Wenn du Fragen hast immer gern. Ich würde vorschlagen wir unterhalten uns dann aber per Mail oder Jabber, das führt in den Kommentaren sonst etwas zu weit ;-)

Viele Grüße

Leonard

Leonard

Moin moin,
lässt sich mit diesem Setup auf AP2 irgendwie ein Repeater realisieren, der die selbe ESSID wie AP1 besitzt? Wenn ich eine Konfiguration im AP Modus einrichte, läuft plötzlich nichts mehr und ich muss beide Konfigurationen entfernen.

Robert Kaussow

Hi Leonard ,

das sollte gehen :-) Am einfachsten ist es natürlich wenn beide Access Points 2,4/5 GHz unterstützen. Dann kannst du die Bridge einfach über das 5 GHz Band aufbauen und auf jedem AP im 2,4 GHz Bereich einen Zugangspunkt mit der selben SSID anlegen. Ich gehe mal davon aus, das dass bei dir aber nicht der Fall ist. Dann konfigurierst du die Bridge wie beschrieben und legst auf AP2 einen virtuellen Zugangspunkt an. Das ist hier im Wiki ganz gut beschrieben. Der Artikel bezieht sich zwar auf die Einrichtung eines Gast-WLANs, die Anlage des Zugangspunktes ist aber die gleiche. Den virtuellen Zugangspunkt kannst du dann mit der selben SSID konfigurieren. Bedenke bitte, dass bei einer Repeater-Lösung das WLAN-Handover von den Clients abhängig ist, eventuell sollte man hier etwas mit der Sendeleistung von AP1 und AP1 experimentieren um ein besseres Handover zu erreichen.

Matthias

Matthias

Besteht noch das Problem mit Hängern beim Seitenaufruf?

Antwort ,

Robert Kaussow

Hi Matthias,
gelegentlich dauert der Seitenaufbau etwas länger. Das behindert mich aber weder beim surfen noch beim streamen :-) ich hab bis jetzt aber noch nicht raus gefunden woran es liegt.

Antwort ,
Florian

Florian

Hallo,

sehr hilfreicher Beitrag.
Nun hab ich mal eine Frage :
Ich habe ein Open WRT Gerät als Bridged AP laufen und möchte das WLAN mit
einem Fritz 310 Repeater verlängern.
Nur bekomme ich den 310er nicht mit den OpenWRT Gerät zum laufen.
Hast du evtl. eine Idee ob man da noch was machen kann ?

Florian

Robert Kaussow

Hi,
schön wenn dir der Artikel gefallen hat. Um deine Frage zu beantworten bräuchte ich etwas mehr Informationen. Was genau heißt nicht zum laufen? Was sagen die Logfiles von OpenWRT?

Pascal

Pascal

Hey Robert,

eine wirklich gute Anleitung, die mir schnell und einfach geholfen hat. Mein Setting: Fritz!Box 7490 (AP1) TP-Link TL-WR841N (AP2; um die LAN-Ports vom TV, BluRay-Player, Raspberry Pi an das zu weit entfernte WLAN zu bekommen.

Die Einrichtung verlief komplett über die Weboberfläche, was mit deinen Steps kein Problem war. Nur eine Frage hätte ich noch, da ich dies bei allen anderen Anleitungen nicht gefunden habe: Warum aktivierst du im LAN-Interface das Spanning-Tree-Protokoll? (option stp '1')

Ich habe es bisher noch nicht ohne gestestet, aber per Default ist es nicht aktiviert und alle anderen Anleitung bezüglich OpenWRT und relayd kommen ohne aus.

Viele Grüße,
Pascal

Robert Kaussow

Hallo Pascal,

freut mich das alles geklappt hat. Natürlich kannst du die Bridge auch ohne Spanning-Tree-Protokoll betreiben. Sollte man aus irgend welchen Gründen allerdings Netzwerkloops produziert haben, sorgt STP dafür das diese Loops erkannt und blockiert werden. Es ist also nur ein Schutz vor bspw. fehlerhafter Verkabelung.

Viele Grüße
Robert

Pascal

Pascal

Ah, interessant. Ich habe auch nochmal etwas recherchiert und bin beim DD-WRT-Wiki auf folgende Info gestoßen:

"Mesh networks without STP enabled may experience Loopback. The need for STP occurs when your router is being used in a mesh network with multiple WDS-enabled repeaters, or in an ad hoc network with multiple ad hoc connections.

If your router is not being used in either of the given scenarios, then likely STP is not necessary. Therefore, it is recommended that you disable it because newly-connected ports sit in a learning state for approximately 50 seconds before entering a non-blocking mode. This can cause certain services on the client device (such as DHCP) to time-out."
Quelle: https://www.dd-wrt.com/wiki/index.php/SpanningTreeProtocol

Könnte dies vielleicht mit den Verzögerungen im Seitenaufbau zu tun haben, der hier in den Kommentaren zuvor beschrieben wurde? Für mich klingt das zumindest so, dass ich in meinem einfachen Netzwerk (= 2 APs) eher von STP Abstand halten sollte.

Robert Kaussow

Ich kann nicht grundsätzlich ausschließen, dass die "Verzögerung" mit STP zusammenhängt. Allerdings heißt es in der genannten Quelle "newly-connected ports sit in a learning state for approximately 50 seconds before entering a non-blocking mode" Das bedeutet für mich, neue Geräte die ich zum ersten Mal mit dem Port verbinde befinden sich für etwa 50 Sekunden im Lernmodus (genau genommen durchläuft ein neues Gerät in dieser Zeit die Statis Blocking - Listening - Learning - Forwarding). Nach dem Wechsel in den Status Forwarding sollte das Problem nicht mehr auftreten. Wie gesagt, du kannst die Bridge auch ohne STP nutzen :-)

Roland

Roland

Hallo,
ist es möglich beide WiFI Bänder 2,4 und 5ghz zu kombinieren um eine noch stärkerer Brücke zu erhalten?
Viele Hersteller zählen die Übertragungsraten der Bänder zusammen und werben mit unglaubwürdig hohen Datenraten. zb ~800 + ~400= 1300Mbit. Wenn man diese Datenraten schon zusammenzählt, sollte es doch auch irgendwie möglich sein.
Kann man Openwrt derart konfigurieren, dass beide Bänder gleichzeitig ausgenutzt werden und parallel zu einem Master verbinden?

Ich habe eine Asus ac66u Router. Dieser sollte "simultan" unterstützen. Ich überlege, einen Openwrt Client aufzubauen, der 2,4 und 5ghz gleichzeitig als "Mediabridge" ausnutzt.
Habe diesebzüglich noch keine genauen Angaben gefunden. Asus bietet entsprechend teure Geräte an. Lieber würde ich mit OpenWrt selber sowas aufbauen. Ich möchte dadurch ein NAS über WLAN anbinden.
Kannst du mir einen Tipp oder Link zu einer Anleitung/Erklärung geben? Welche Hardware wäre dafür zu empfehlen? (Gbit wäre natürlich Pflicht!)
lg
Roland

Robert Kaussow

Hi Roland,
sehr komplexe Frage :-) Ich versuche das mal Stück für Stück zu beantworten.

Meines Wissens nach ist die Bündelung von 2,4 und 5GHz nicht möglich. Die meisten modernen Router können können zwar beide Bänder gleichzeitig verwenden, das bedeutet aber nur es können sich gleichzeitig Geräte per 2,4GHz und 5GHz verbinden. Was du machen kannst ist Channel Bonding, dabei werden mehrere Kanäle (im selben Band) gebündelt und ermöglichen dadurch eine (theoretisch) höhere Übertragungsrate. Wlan-Accesspoints die mindestens den Standard "n" erfüllen können zwei Kanäle bündeln und erreichen damit einen 40MHz Kanal (anstatt der üblichen 20MHz). Accesspoints mit dem Standard "ac" erlauben sogar 80MHz und 160MHz Kanäle. Allerdings hat das Ganze auch einen Nachteil. Gerade im 2,4GHz Band führt die Bündelung auf Grund des schmalen Frequenzbereiches eher zu Problemen als das es irgendwas nützt. Im 5GHz Band ist es dagegen etwas unproblematischer.

Generell kannst du die Bridge natürlich per OpenWRT umsetzen wie im Artikel beschrieben. Im besten Falle nutzt du dazu zwei "ac" Router und verwendest für die Bridge das 5GHz Band um eine möglichst hohe und stabile Verbindung aufzubauen. Eine Geräteempfehlung ist nicht einfach, oft gibt es bei Geräten unterschiedliche Versionen die dann mehr oder weniger gut unterstützt werden. Schau dir am besten mal diese Liste an. Auf die schnelle würde ich mal die Geräte TP-Link TL-WDR4900 und Asus RT-N66U (kein AC) in den Raum werfen.

Das Thema der Addierung der Übertragungsraten ist natürlich eine etwas fragliche Praxis der Hersteller. Hier mal eine Beispielrechnung von TP-Link 450 Mbit/s(2,4GHz)+1300 Mbit/s(5GHz). Beide Wlan Bänder haben zusammen eine theoretische Gesamtleistung von 1750 Mbit/s wenn man es so will sogar gleichzeitig aber eben nicht gebündelt sondern lediglich zur selben Zeit auf zwei verschiedenen Bändern :-) Also ein Gerät kann auf dem 2,4GHz Band die Bandbreite ausnutzen und ein anderes Gerät zur selben Zeit die Bandbreite im 5GHz Band.

Ich hoffe ich konnte helfen, wenn noch Fragen sind einfach melden.

Gruß
Robert

Roland

Roland

Hallo,
danke für die ausführliche Antwort. Jetzt kenne ich mich aus! Ich möchte/muss ein NAS per WLan anbinden. Das NAS soll natürlich maximale Übertragungsraten bieten. Egal, das werde ich irgendwie lösen.

Frage zum Thema "Brücke":
Ich habe nach deiner Anleitung einen TPlink OpenWRT Router als Brücke eingerichtet. Die LAN IP soll nach deiner (und allen offiziellen) Anleitung auf einem anderen Subnetz liegen. ("option ipaddr '192.168.10.1'"
Das funktioniert soweit, jedoch "verliert" mein TPRouter die Internetanbindung sobald ich LAN IP auf ein andere Subnetz (192.168.2.1) umstelle. Lasse ich die LAN IP im allgemeinen Subnetz (192.168.1.2), dann bleibt auch die Brücke online.
Abgesehen davon, funktioniert alles wunderbar. Habe es nur zufällig rausgefunden, da "IPKG update" und ping nicht mehr funzte.

warum muß die LAN IP auf einem anderen Subnetz liegen? Was muß ich einstellen, um die Brücke online zu halten? (DNS auf 8.8.8.8 und gateway 192.168.1.1 habe ich erfolglos getestet)

Kann es sein, dass die "Gegenseite", in meinem Fall der Asus Router anders konfiguriert werden muß? Ich dachte mit dieser Brücke kann ich jedes bestehende Wlan um ein paar LAN Anschlüsse erweitern..

Vielleicht kannst du mir helfen!

Robert Kaussow

Hi,
also ich bin mir ziemlich sicher, dass du den ASUS Router nicht anfassen musst. Ich selbst betreibe die Bridge in einem 192.168.0.* Subnetz ohne Probleme. Mir sind keine Restriktionen bekannt die dich daran hindern sollten eine beliebige IP Adresse zu verwenden. Bist du dir sicher, dass du für die Interfaces "wwan" und "stabridge" die selbe IP vergeben hast? Stimmt die Subnetzmaske für das verwendete Subnetz im Interface "wwan"? Warum man für das "lan" Interface ein eigenes Subnetz benötigt kann ich dir aus dem Stand nicht sagen.

Roland

Roland

Hallo,
.. .
Trage ich bei stabridge und wwan die selbe IP ein (192.168.1.3), und Lan IP 192.168.2.1, kann ich nichtmehr auf die Bridge zugreifen.
sowohl unter *.1.3 als auch *.2.1 mit entsprechender IP am PC ist die Bridge nicht erreichbar.

Ich habe jetzt die Bridge LAN auf 192.168.1.2 gestellt
Asus Router ist 192.168.1.1
Starbridge hat KEINE IP! (Vorher auch 192.168.1.3)
WWAN hat 192.168.1.3

Die Bridge erreiche ich ab dem Moment wo ich Stabridge aktiviere, nur noch über 192.168.1.3. Über die LAN Ip erreiche ich sie nichtmehr. Auch mit angepasster PC IP nicht.

Vielleicht ists die Firewall. Kann sich die selber wieder aktivieren? kann man die Pakete deinstallieren?
hab sie mit stop und deaktivate über putty abgedreht.
Irgendwie komme ich übers Lankabel nichtmehr auf die Brücke. Nur über den Umweg über den Asus router. Verliert die Brücke den Wlan Kontakt, habe ich auch keinen Zugriff mehr.

Die Brücke an sich, funktioniert. Ich kann von der Brücke auf IPs hinter dem Asus Wlan Router zugreifen und komme problemlos ins Netz.
Da die starbridge jetzt keine IP hat und wider aller Anleitungen LAN auf dem selben Netz liegt, erwart ich jedoch, dass irendwetwas falsch rennt.
was bedeuted "option stp '1' # Spanning Tree Protokoll aktivieren" ?

Robert Kaussow

Hi,
also irgendwie kann ich dir nicht mehr ganz folgen. Du schreibst:

Ich habe jetzt die Bridge LAN auf 192.168.1.2 gestellt
Asus Router ist 192.168.1.1
Starbridge hat KEINE IP! (Vorher auch 192.168.1.3)
WWAN hat 192.168.1.3


Hier ist doch schon grundlegend was falsch. LAN auf dem AP2 im selben Netzsegment wie der Asus funktioniert nicht! Das LAN Interface muss zwingend in ein anderes Subnetz (z. B. 192.168.10.X).

Die Bridge erreiche ich ab dem Moment wo ich Stabridge aktiviere, nur noch über 192.168.1.3. Über die LAN Ip erreiche ich sie nichtmehr. Auch mit angepasster PC IP nicht.

Das ist absolut richtig so. Da sich das LAN Interface sowieso in einem anderen Netzsegment befinden soll (siehe oben) greifst du auf den AP normalerweise per WWAN/STABRIDGE IP-Adresse zu.

Vielleicht ists die Firewall.

Würde ich ausschließen, wenn du die beendet und deaktiviert hast aktiviert die sich im Regelfall nicht von selbst wieder. Wenn die das lieber ist kannst du das Paket mit opkg aber deinstallieren.

was bedeuted "option stp '1' # Spanning Tree Protokoll aktivieren"

Dazu gibts hier nähere Infos, die Einstellung kannst du aber gern deaktivieren, sollte auch das Setup keinen Einfluss haben.

Edit: Schick mir doch mal deine Konfiguration von /etc/config/network per mail

Tobi

Tobi

Hallo,
ich möchte mit Openwrt eine Bridge betreiben um damit am 2. AP eine Webcam per Ethernet zu verbinden. Ich sitze schon den ganzen Tag daran und verzweifle fast. WDS Client hat unzuverlässig funktioniert, sodass ich das jetzt mit der Realy Bridge gemacht habe (obwohl ich das als ITler nicht so 100 %ig verstehen schande komme über mich). Aber ich kann auf den AP zugreifen und er hat Verbindung ins Internet. Aber: Wie muss ich jetzt die physikalische eth0 Schnittstelle konfigurieren, damit die daran anzuschließende Webcam eine IP aus dem IP Adressbereich meines Netzes erhält ?

Beat

Beat

Hallo

Sehr schöner Artikel!! Habe leider das Problem, dass mein AP1 den dns server meines Netzwerks nutzen soll (globaler dns in meinem Netz), nicht selber dns server spielen. Wenn ich mich zum 1.AP verbinde via wireless bekomme ich die richtige ip Adresse von meine globalen dns server, aber wenn ich mich zum 2. AP verbinde via wireless bekommt der eine andere IP Adresse... Wie kann ich das machen?

Robert Kaussow

Hi,
ich vermute du nutzt ein DHCP Server in deinem Netz? IP und DNS werden dann per DHCP an die Clients verteilt. Der DHCP läuft wie der DNS vermutlich auch auf dem AP1. Hast du auf AP2 DHCP und DNS deaktiviert?

Micha

Micha

Besteht die Möglichkeit mehrer SSID's mit einer relayd bridge auf einem Gerät abzubilden. Beispielsweise auf einem TP-LINK WR-841N
Also folgende Logik:
SSID alpha -> relayd bridge alpha -> Switch Ports 1+2
SSID beta -> relayd bridge beta -> Switch Ports 3+4

Robert Kaussow

Hi,
ich bezweifle ehrlich gesagt, dass das geht habs aber selber nie getestet.

Christian

Christian

Hi,

gibt es eigentlich auch eine Möglichkeit das openwrt die Einstellungen speichert?

Denn jedesmal wenn ich den Strom abklemme, sind meine Einstellungen weg und ich kann jedesmal von Vorne anfangen.

Als Router Hardware habe ich einen DLink DIR-645 im Einsatz und meine openwrt Version ist die Chaos Calmer 15.05.1

Grüße

Christian

Robert Kaussow

Hi,

puh kann ich jetzt aus dem Stand nichts zu sagen. Hatte bisher das Problem bei keinem meiner OpenWRT Router ist also kein generelles Problem.

Benjamin B.

Benjamin B.

Hallo Christian,

sind alle deine Einstellungen weg oder nur ein Teil?
Wenn nur ein Teil davon betroffen ist, prüfe doch mal ob du auf deinem Router zu viele Pakete installiert hast - also deinen Speicher vollgeschrieben hast.

System -> Software -> Free Space

Grüße

Fritz

Fritz

Hallo Robert,
ich finde deinen Artikel absolut toll, möchte aber eine Config erstellen, die ein klein wenig anders aussieht.
Ich möchte das bestehende Wlan mittels eines zweiten Routers erweitern. Die Verbindung jedoch zwischen den beiden Routern ist ein Kabel.
Am zweiten Router soll sowohl das Wlan (Home und Guest) als auch die 1000Mbit Schnittstellen genutzt werden können. DHCP Server soll weiterhin der Hauptrouter sein. Ich kämpfe schon eine Weile, krieg es irgendwie nicht hin.
Hast du eine gute Idee, wie das funktioniert? Bin kein Laie, aber da stoße ich an meine Grenzen.
Besten Dank,
Fritz

Robert Kaussow

Hi Fritz,

ungetestete Lösung: die beiden integrierten Switche per LAN-Kabel verbinden sollte eigentlich ohne Probleme funktionieren. Damit sollten dann an beiden Switchen Verbindungen möglich sein. Andere Option ist den DSL-Port beider Geräte als Upstream-Link zu benutzen da muss man aber 100% was konfigurieren.

Zum Thema WLAN, das ist eigentlich relativ simpel und bedarf keiner großen Konfiguration. Dazu auf beiden Geräten das WLAN mit der selben SSID konfigurieren. Die Clients wechseln dann automatisch zum AP mit der besseren Signalstärke. Allerdings ist dieses sogenannte clientseitige Handover nicht ganz trivial und durchaus fehleranfällig.

Beste Grüße,
Robert

Anonym

Besten Dank für deine Antwort.
Das mit der Verbindung der Switche habe ich soweit schon hinbekommen, das Problem war eher die Wireless Konfig. Als Client hat es garnicht funktioniert, wäre schön gewesen, da keine zus. config für Mac Adressen, Firewall, etc. notwendig gewesen wäre.
Damit muß ich wohl in den sauren Apfel beissen und den zweiten Router als AP mit allen dazu notwendigen Configs herrichten.
Beste Grüße
Fritz

Daniel

Daniel

Hi,

danke für die Anleitung. Ich nutze einen TP-Link CPE510 mit dem aktuellen Build. Die Bridge funktioniert soweit, Adressvergabe vom DHCP funktioniert wie gewünscht. Jetzt möchte ich gern noch 2 VLANS getagged mit über die Bridge transportieren. Was muss ich dafür noch konfigurieren? Habe am an beiden Ender der Bridge jeweils einen Switch der die Frames des entsprechenden VLANs tagged.

Grüsse
Daniel

Kommentar schreiben

Die angegebene E-Mail-Adresse wird nicht veröffentlicht, sondern nur für eventuelle Benachrichtigungen verwendet.
Die Formatierung der Kommentare ist über Markdown möglich.
Standard-Text Smilies wie :-) und ;-) werden zu Bildern konvertiert.
Die angegebene E-Mail-Adresse wird nicht dargestellt, sondern nur für eventuelle Benachrichtigungen verwendet.
Gravatar Autoren-Bilder werden unterstützt.
Markdown-Formatierung erlaubt